POJ-1840 Eqs

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 14929   Accepted: 7329

Description

Consider equations having the following form:
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

Source

Romania OI 2002


分析:很容易想到半路相遇法,枚举前两个变量的值并放入hash表中,然后再枚举后三个值查询并累加结果。

#include <cstdio>
#include <cmath>
#include <iostream>
using namespace std;
int a1,a2,a3,a4,a5,ans,f[2000007],val[2000007];
bool jud[2000007];
void insert(int x)
{
	int k=abs(x) % 1300707;
	while(jud[k] && f[k] != x) k++;
	if(!jud[k])
	{
		jud[k]=true;
		f[k]=x;
	}
	val[k]++;
}
int Find(int x)
{
	int k=abs(x) % 1300707;
	while(jud[k] && f[k] != x) k++;
	return(val[k]);
} 
int main()
{
	cin.sync_with_stdio(false);
	cin>>a1>>a2>>a3>>a4>>a5;
	for(int i=-50;i <= 50;i++)
	 for(int j=-50;j <= 50;j++)
	  if(i*j) insert(-(a4*i*i*i+a5*j*j*j));
	for(int i=-50;i <= 50;i++)
	 for(int j=-50;j <= 50;j++) 
	  for(int k=-50;k <= 50;k++)
	   if(i*j*k && abs(a1*i*i*i+a2*j*j*j+a3*k*k*k) <= 2*6250000) ans+=Find(a1*i*i*i+a2*j*j*j+a3*k*k*k);	
	cout<<ans<<endl;
} 


你可能感兴趣的:(POJ-1840 Eqs)