POJ 2421 Constructing Roads(最小生成树简单题目)

Constructing Roads
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21881 Accepted: 9295
Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output

179
Source

本题基本上是一个最小生成树的简单题目,关于最小生成树,还是建议大家尽量不用模板。模板对一个人的危害实在太大了,所以大家还是靠自己手敲吧,
下面是AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

struct node
{
    int u,v,cost;
}a[10005];
int pre[105];
int fin(int x)
{
    if(x==pre[x])
    {
        return x;
    }
    else
    {
        return pre[x]=fin(pre[x]);
    }
}

void join(int x,int y)
{
    int t1=fin(x);
    int t2=fin(y);
    if(t1!=t2)
    {
        pre[t1]=t2;
    }
}

bool cmp(node x,node y)
{
    return x.cost<y.cost;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<=n;i++)
        {
            pre[i]=i;
        }
        int num,cnt=0;;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&num);
                a[cnt].u=i;
                a[cnt].v=j;
                a[cnt].cost=num;
                cnt++;
            }
        }
        sort(a,a+cnt,cmp);
        int sum1=0,sum=0;//此处算是一个小剪枝吧
        int q;
        scanf("%d",&q);
        int c,d;
        for(int i=0;i<q;i++)
        {
            scanf("%d%d",&c,&d);
            if(fin(c)!=fin(d))
            {
                join(c,d);
                sum1++;
            }
        }
        for(int i=0;i<cnt;i++)
        {
            if(fin(a[i].u)!=fin(a[i].v))
            {
                join(a[i].u,a[i].v);
                sum+=a[i].cost;
                sum1++;
            }
            if(sum1==n-1)
            {
                break;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

你可能感兴趣的:(poj)