【郑轻oj】1312-Red and Black (搜索)

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14322    Accepted Submission(s): 8876


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input
   
   
   
   
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
   
   
   
   
45 59 6 13
 

Source
Asia 2004, Ehime (Japan), Japan Domestic

第一次接触搜索啊,想想挺激动。


代码如下:

#include <stdio.h>
char map[22][22];
int move_x[4]={0,0,-1,1};
int move_y[4]={1,-1,0,0};		//移动
int x,y,stp;
int W,H;
void dfs(int x,int y)
{
	if (x<0||x>=H||y<0||y>=W)
		return;
	if (map[x][y]=='#')
		return;
	stp++;
	map[x][y]='#';
	for (int i=0;i<4;i++)
		dfs(x+move_x[i],y+move_y[i]);
}
int main()
{
	while (~scanf ("%d %d",&W,&H) && (W||H))
	{
		for (int h=0;h<H;h++)
		{
			scanf ("%s",map[h]);
			for (int j=0;j<W;j++)
			{
				if (map[h][j]=='@')
				{
					x=h;
					y=j;
				}
			}
		}
		stp=0;
		dfs(x,y);
		printf ("%d\n",stp);
	}
	return 0;
}




你可能感兴趣的:(【郑轻oj】1312-Red and Black (搜索))