周赛一 HDU 2147 博弈论

Description

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?  
 

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.  

 

Output

If kiki wins the game printf "Wonderful!", else "What a pity!".  
 

Sample Input

     
     
     
     
5 3 5 4 6 6 0 0
 

Sample Output
     
     
     
     
What a pity! Wonderful! Wonderful!


P点:就是P个石子的时候,对方拿可以赢(自己输的)

N点:就是N个石子的时候,自己拿可以赢

现在关于P,N的求解有三个规则

(1):最终态都是P

(2):按照游戏规则,到达当前态的前态都是N的话,当前态是P

(3):按照游戏规则,到达当前态的前态至少有一个P的话,当前态是N

题意:

在一个m*n的棋盘内,从(1,m)点出发,每次可以进行的移动是:左移一,下移一,左下移一。然后kiki每次先走,判断kiki时候会赢(对方无路可走的时候)。

我们可以把PN状态的点描绘出来::

周赛一 HDU 2147 博弈论_第1张图片


#include<iostream>
#include<cstring>

using namespace std;

int main()
{
	int n,m;
	while(cin>>n>>m)
	{
		if(n==0&&m==0)
			break;
		if(n*m%2==0)
		cout<<"Wonderful!\n";
		else
			cout<<"What a pity!\n";
	}
}






你可能感兴趣的:(周赛一 HDU 2147 博弈论)