poj3461解题报告

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6114   Accepted: 2329

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0
 
 题意:在最大长度为100万的字符串中查找长度不超过1万的另一字符串出现的次数。。。
思路:主串长度100万,字串1万,朴素算法肯定超时,前两天刚看懂算法导论上的KMP,现在派上用场了。。写了个KMP,90+MS过了。。。
#include<iostream>
using namespace std;
int go[10010],m,n,s;	char T[1000010],P[10010];

void get()
{
	int i,k=-1;
	go[0]=-1;
	for(i=1;i<m;i++)
	{
		while(k!=-1&&P[k+1]!=P[i])
			k=go[k];
		if(P[k+1]==P[i])
			k++;
		go[i]=k;
	}
}

void f()
{
	get();
	int i,k=-1;
	for(i=0;i<n;i++)
	{
		while(k!=-1&&P[k+1]!=T[i])
			k=go[k];
		if(P[k+1]==T[i])
			k++;
		if(k==m-1)
		{
			s++;
			k=go[k];
		}
	}
}

int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		scanf("%s%s",P,T);
		s=0;
		m=strlen(P);	n=strlen(T);
		f();
		cout<<s<<endl;


	}


	return 0;
} 

你可能感兴趣的:(poj3461解题报告)