HDOJ 1856 More is better (并查集)

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 18615    Accepted Submission(s): 6848


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
   
   
   
   
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
  
  
4 2 题目大意:求的最大的一棵树有多少人 ac代码:
#include<stdio.h>  
#include<string.h>  
#include<iostream>  
#include<algorithm>  
#define MAXN 10000000
using namespace std;  
int pri[MAXN];  
int num[MAXN];  
//int v[MAXN];
int find(int x)  
{  
    int r=x;  
    while(r!=pri[r])  
    {  
        r=pri[r];  
    }  
    int i=x,j;  
    while(i!=r)  
    {  
        j=pri[i];  
        pri[i]=r;  
        i=j;  
    }  
    return r;  
}  
void connect(int xx,int yy)  
{  
    int a=find(xx);  
    int b=find(yy);  
    if(a!=b) 
	{ 
    pri[a]=b; 
	num[b]+=num[a]; //加上后面带的树枝
    }
}  
int main()  
{  
    int t,j;  
    int n,m,i;
	int max;  
    while(scanf("%d",&t)!=EOF)
	{  
	    if(t==0)//略坑
	    {
	    	printf("1\n");
	    	continue;
		}
	    for(i=1;i<=MAXN;i++)
	    {
	    	pri[i]=i;
	    	//v[i]=0;
	    	num[i]=1;//数量刚开始都是自身,所以是1
		}
		max=0;
		while(t--)
		{
		    scanf("%d%d",&n,&m);  
		    if(n>max)  //求得输入的数字最大是多少,因为爆过一次,所以加上这个
                max=n;  
            if(m>max)  
                max=m; 
		    connect(n,m);
			//v[n]=v[m]=1;     
		}
		int reallymax=0; 
	    //int sum;  
	    for(i=1;i<=max;i++)//直接从1求到max出即可,求出真正最大值
	    {
	    	if(num[i]>reallymax)
                reallymax=num[i];
		}
	    printf("%d\n",reallymax);  
    }
    return 0;  
}  


你可能感兴趣的:(HDOJ 1856 More is better (并查集))