Integer Inquiry(大数)

A - Integer Inquiry
Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu
Submit Status

Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670

AC代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int ia[220], ib[220], ic[220];
int lena, lenb, lenc;
char a[220], b[220];

int main()
{
#ifdef LOCAL
    freopen( "input.txt", "r", stdin );
#endif // LOCAL
    int i, flag = 0;
    memset(b, 0, sizeof(b));
    while(1)
    {
        memset(a, 0, sizeof(a));
        gets(a);
        if( !strcmp("0", a) )
            break;
        memset(ib, 0, sizeof(ib));
        memset(ia, 0, sizeof(ia));
        memset(ic, 0, sizeof(ic));
        lena = strlen(a);
        if( !flag )
        {
            gets(b);
        }
        lenb= strlen(b);
        lenc = 0;
        for( i=0; i<lena; i++ )
        {
            ia[i] = a[lena-i-1]-'0';
        }
        for( i=0; i<lenb; i++ )
        {
            ib[i] = b[lenb-i-1]-'0';
        }
        int g = 0;
        for( i=0; i<max(lena, lenb)+1; i++ )
        {
            int x = g;
            if( i < lena )
                x += ia[i];
            if( i < lenb )
                x += ib[i];
            ic[lenc++] = x % 10;
            g = x / 10;
        }
        memset(b, 0, sizeof(b));
        for( i=0; i<lenc; i++ )
        {
            b[lenc-i-1] = ic[i]+'0';
        }
        flag = 1;
    }
    for( i=219; i>=0; i-- )
        if( ic[i] != 0 )
            break;
    if( -1 == i)
        printf("0");
    else
        for( ; i>=0; i-- )
            printf("%d", ic[i]);
    printf("\n");
    return 0;
}

我这个傻逼,找个错误找了两天,最后原因是最后一次相加没有进位,丫的

你可能感兴趣的:(Integer Inquiry(大数))