Catch That Cow(bfs)

B - Catch That Cow
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 3278

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a pointN (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 orX + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

ac代码:
#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>

using namespace std;

const int MAXN = 1e6;
int vis[MAXN], step[MAXN];

queue <int> q;

int main()
{
    memset(vis, 0, sizeof(vis));
    memset(step, 0, sizeof(step));
    int n, k, i, x, dx, flag = 0;
    scanf("%d%d", &n, &k);
    q.push(n);
    vis[n] = 1;
    while( !q.empty() )
    {
        x = q.front();
        q.pop();
        for( i=0; i<3; i++ )
        {
            if( 0 == i )
                dx = x*2;
            else if( 1 == i)
                dx = x+1;
            else if( 2 == i )
                dx = x-1;
            if( dx>=0 && dx<MAXN && !vis[dx] )
            {
                vis[dx] = 1;
                step[dx] = step[x]+1;
                q.push(dx);
            }
            if( dx == k )
            {
                flag = 1;
                break;
            }
        }
        if( flag )
            break;
    }
    printf("%d\n", step[k]);
    return 0;
}

感冒了,注意力真的分散了,T T

你可能感兴趣的:(Catch That Cow(bfs))