HDU 4287 Intelligent IME

Intelligent IME

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1229    Accepted Submission(s): 638


Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o    
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
 

Sample Input
   
   
   
   
1 3 5 46 64448 74 go in night might gn
 

Sample Output
   
   
   
   
3 2 0
 

Source
2012 ACM/ICPC Asia Regional Tianjin Online
 

Recommend
liuyiding



水题 纯模拟就行了  不过要注意一下 有可能会TLE

//TLE 的代码

#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
using namespace std;

char num[5005][5005];
char str[5005];
int ans[5005];
int lenn[5005];
int N, M;
void slove()       //这里面的temp和ans用了字符串处理导致了TLE
{
	int i, j;
	int len = strlen(str);
    char temp[5005];
	for(i = 0;i < len;i++)
	{	
	    if(str[i]>= 'a' && str[i] <= 'c')  temp[i] = '2';
	    else if(str[i]>= 'd' && str[i] <= 'f')  temp[i] = '3';
		else if(str[i]>= 'g' && str[i] <= 'i')  temp[i] = '4';
		else if(str[i]>= 'j' && str[i] <= 'l')  temp[i] = '5';
		else if(str[i]>= 'm' && str[i] <= 'o')  temp[i] = '6';
		else if(str[i]>= 'p' && str[i] <= 's')  temp[i] = '7';
		else if(str[i]>= 't' && str[i] <= 'v')  temp[i] = '8';
		else if(str[i]>= 'w' && str[i] <= 'z')  temp[i] = '9';	
	}
	temp[i] = '\0';
	for(i = 1; i <= N; i++)
	{
		if(len != lenn[i])  continue;
		if(strcmp(num[i],temp) == 0)  ans[i]++;
	}

}


int main ()
{
	int T;
	int i, j;
	scanf("%d", &T);
	while(T--)
	{
		memset(ans, 0, sizeof(ans));
		scanf("%d %d",&N, &M);
		for(i = 1; i <= N; i++)
		{
			scanf("%s", &num[i]);
		    lenn[i] = strlen(num[i]);
		}
		
		for(i = 1; i <= M; i++)
		{
			scanf("%s", str);
		    slove();
		}
		
		for(i = 1; i <= N; i++)
			printf("%d\n", ans[i]);
	}
	return 0;
}



//AC 的代码  
#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
using namespace std;

int num[5005];
char str[5005];
int ans[5005];

int N, M;
void slove() //这里面的ans和temp都用了int型处理  
{
	int i, j;
	int len = strlen(str);
        int temp = 0;
	for(i = 0;i < len;i++)
	{	
		temp = temp * 10;
	    if(str[i]>= 'a' && str[i] <= 'c')       temp = temp + 2;
	    else if(str[i]>= 'd' && str[i] <= 'f')  temp = temp + 3;
		else if(str[i]>= 'g' && str[i] <= 'i')  temp = temp + 4;
		else if(str[i]>= 'j' && str[i] <= 'l')  temp = temp + 5;
		else if(str[i]>= 'm' && str[i] <= 'o')  temp = temp + 6;
		else if(str[i]>= 'p' && str[i] <= 's')  temp = temp + 7;
		else if(str[i]>= 't' && str[i] <= 'v')  temp = temp + 8;
		else if(str[i]>= 'w' && str[i] <= 'z')  temp = temp + 9;
	}
	
	for(i = 1; i <= N; i++)
		if(temp == num[i])  
			ans[i]++;
}


int main ()
{
	int T;
	int i, j;
	scanf("%d", &T);
	while(T--)
	{
		memset(ans, 0, sizeof(ans));
		scanf("%d %d",&N, &M);
		for(i = 1; i <= N; i++)
			scanf("%d", &num[i]);	
		
		for(i = 1; i <= M; i++)
		{
			scanf("%s", str);
		    slove();
		}
		
		for(i = 1; i <= N; i++)
			printf("%d\n", ans[i]);
	}
	return 0;
}



你可能感兴趣的:(HDU 4287 Intelligent IME)