An easy problem
Time Limit: 8000/5000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 53 Accepted Submission(s): 22
Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
Input
The first line is an integer T(
1≤T≤10 ), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. (
1≤Q≤105,1≤M≤109 )
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. (
0<y≤109 )
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)
It's guaranteed that in type 2 operation, there won't be two same n.
Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
Sample Input
1
10 1000000000
1 2
2 1
1 2
1 10
2 3
2 4
1 6
1 7
1 12
2 7
Sample Output
Case #1:
2
1
2
20
10
1
6
42
504
84
Source
2015 ACM/ICPC Asia Regional Shanghai Online
Recommend
hujie
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define LL long long
#define lson L, mid, rt << 1
#define rson mid + 1, R, rt << 1 | 1
#define N 100000 + 10
int val[N << 2];
int n, M;
void pushup(int rt)
{
val[rt] = ((LL)val[rt << 1] * val[rt << 1 | 1]) % M;
}
void build(int L, int R, int rt)
{
if(L == R)
{
val[rt] = 1;
return ;
}
int mid = (L + R) >> 1;
build(lson);
build(rson);
pushup(rt);
}
void update(int q, int v, int L, int R, int rt)
{
if(L == R)
{
val[rt] = v;
return ;
}
int mid = (L + R) >> 1;
if(q <= mid) update(q, v, lson);
else update(q, v, rson);
pushup(rt);
}
int main()
{
int kase = 0;
int T;
scanf("%d", &T);
while(T--)
{
printf("Case #%d:\n", ++kase);
scanf("%d%d", &n, &M);
build(1, n, 1);
int op, y;
for(int i = 1; i <= n; i++)
{
scanf("%d%d", &op, &y);
if(op == 1)
{
update(i, y, 1, n, 1);
printf("%d\n", val[1]);
}
else
{
update(y, 1, 1, n, 1);
printf("%d\n", val[1]);
}
}
}
return 0;
}
/*
1
10 1000000000
1 2
2 1
1 2
1 10
2 3
2 4
1 6
1 7
1 12
2 7
*/