HDU1042

N!

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 67489 Accepted Submission(s): 19343

Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input
One N in one line, process to the end of file.

Output
For each N, output N! in one line.

Sample Input
1
2
3

Sample Output
1
2
6

大数运算
思路是把数字拆开存在数组里
比如:有一个很大的数进行操作12345678910111213*99
有个数组a
我们把数字存成下面这样
a[0]=11213,a[1]=89101,a[2]=34567,a[3]=12
再对数组的每一个单元进行*99运算,注意如果有进位就要把进了多少加到下个格子里去,大概就酱紫。每个单元最大的数字可以随便设只要做除法和模的时候稍稍改下就好了。

// HDU1042.cpp: 主项目文件。

#include "cstring"
#include "cstdio"
#include "iostream"
#include "iomanip"
using namespace std;



int main()
{
    int a[10000];
    int n;
    while (scanf("%d", &n) != EOF)
    {
        a[0] = 1;
        int k = 0;
        int count = 0;
        for (int i = 1; i <= n; i++)
        {
            int jinwei = 0;
            for (int j = 0; j <= count; j++)
            {
                int temp;
                temp = a[j] * i+jinwei;
                a[j] = temp % 100000;
                jinwei = temp / 100000;
            }
            if (jinwei > 0)
            {
                count++;
                a[count] = jinwei;
            }
        }
        printf("%d", a[count]);
        for (int i = count - 1; i >= 0; i--)
        {
            cout << setw(5) << setfill('0') << a[i];
        }
        cout << endl;
    }

}

你可能感兴趣的:(HDU1042)