G - 寻找大富翁 HDU 3785(对和比大小)

                 开一个数组记录和作为作为下标,从大到小找M个最大下标

Description

浙江桐乡乌镇共有n个人,请找出该镇上的前m个大富翁.

Input

输入包含多组测试用例.
每个用例首先包含2个整数n(0<n<=100000)和m(0<m<=10),其中: n为镇上的人数,m为需要找出的大富翁数, 接下来一行输入镇上n个人的财富值.
n和m同时为0时表示输入结束.

Output

请输出乌镇前m个大富翁的财产数,财产多的排前面,如果大富翁不足m个,则全部输出,每组输出占一行.

Sample Input

3 1
2 5 -1
5 3
1 2 3 4 5
0 0

Sample Output

5
5 4 3
<pre name="code" class="cpp">#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int n,m,i,j,a[100010],t;
    while(~scanf("%d%d",&n,&m)&&(n||m))
    {
        for(i=0; i<n; i++)
            scanf("%d",&a[i]);
        sort(a,a+n);
        for(i=n-1; i>n-1-m; i--)
            if(i==n-1)
                printf("%d",a[i]);
            else
                printf(" %d",a[i]);
        printf("\n");
    }
}


 

你可能感兴趣的:(G - 寻找大富翁 HDU 3785(对和比大小))