Hdu---Text Reverse---1062 java版的注意

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13078    Accepted Submission(s): 4973


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
 

Output
For each test case, you should output the text which is processed.
 

Sample Input
   
   
   
   
3 olleh !dlrow m'I morf .udh I ekil .mca
 

Sample Output
   
   
   
   
hello world! I'm from hdu. I like acm.
 
代码:
#include<stdio.h>
//#include<stdlib.h>
#include<string.h>
//using namespace std;
int main(){
	int n; 
	scanf("%d",&n);
	getchar();
	while(n--){
		char str[1005];
		char str1[100];
		int i,k=0,j=0,t=0,len;
		gets(str);
		//printf("%s",strrev(str));
		len = strlen(str);
		for(i=0,j=0,k=0; i<len; i++){
			if(str[i] != ' '){
				str1[j++]=str[i];
			}
			else{
				if(t>0) printf(" ");
				for(k=j-1; k>=0; k--){
					printf("%c",str1[k]);
				}
				j=0;
				t++;
			}
			if(i==len-1){
				printf(" ");
				for(k=j-1; k>=0; k--){
					printf("%c",str1[k]);
				}
			} 
//strncpy(str1,str,i+1);字符串的拷贝 
//	strrev(str1);字符串逆置 	
		}	
		printf("\n");
	}
	return 0;
}
 
 
 
java版:
import java.util.Scanner;
public class Append {
	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int a =Integer.parseInt(in.nextLine());
		for (; a > 0; a--) {
			String s=in.nextLine();
			String[] str = s.split(" ");
			for (int i = 0; i < str.length; i++) {
				System.out.print(reverseString(str[i]));
				if (i < str.length - 1)
					System.out.print(" ");
			}
			if(s.endsWith(" "))//尤其注意这里,表示最后一个字符后可能有空格
				System.out.print(" ");
			System.out.println();
		}
	}
	private static String reverseString(String string) {
		StringBuffer buf = new StringBuffer();
		buf.append(string);
		return buf.reverse().toString();
	}
}



你可能感兴趣的:(Hdu---Text Reverse---1062 java版的注意)