poj2230 解题报告

Watchcow
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 5222   Accepted: 2187   Special Judge

Description

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done. 

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice. 

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M. 

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS: 

Bessie starts at 1 (barn), goes to 2, then 3, etc...
dfs 虽然简单,但是不好想的,为什么是后面输出,而不是,一开始就输出,这 是很大的讲究的,是因为,先没有出度的,点,一定是先出发的点,所以,这点的顺序是要相反输出的!
#include<iostream>
#include<vector>
#include<stdio.h>
#define N 10005
using namespace std;
struct edge
{
       int x;
       bool flag;
};
vector<edge >map[N];
int n,m;
void dfs(int u)
{
       int i;
      //cout<<u<<"start"<<endl;
       for(i=0;i<map[u].size();i++)
              if(!map[u][i].flag)
              {
                     map[u][i].flag=1;

                     dfs(map[u][i].x);


              }
      cout<<u<<endl;
}
int main()
{
       int i;
       scanf("%d%d",&n,&m);
       for(i=0;i<=n;i++)
              map[i].clear();
              int k=m;
       while(m--)
       {
              int a,b;
              edge tmp;
              scanf("%d%d",&a,&b);
              tmp.x=b;
              tmp.flag=false;
              map[a].push_back(tmp);

              tmp.x=a;
              map[b].push_back(tmp);
       }

       dfs(1);

       return 0;
}


你可能感兴趣的:(poj2230 解题报告)