Maximum continuous product
Time Limit: 1000 MS Memory Limit: 32768 K
Total Submit: 111(37 users) Total Accepted: 34(30 users) Rating: Special Judge: No
Description
Wind and his GF(game friend) are playing a small game. They use the computer to randomly generated a number sequence which only include number 2,0 and -2. To be the winner,wind must
have to find a continuous subsequence whose continuous product is maximum.
For example, we have a sequence blow:
2 2 0 -2 0 2 2 -2 -2 0
Among all of it’s continuous subsequences, 2 2 -2 -2 own the maximum continuous product.
(2*2*(-2)*(-2) = 16 ,and 16 is the maximum continuous product)
You,wind’s friend,can give him a hand.
Input
The first line is an integer T which is the Case number(T <= 200).
For each test case, there is an integer N indicating the length of the number sequence.(1<= N <= 10000)
The next line,there are N integers which only include 2,0 and -2.
Output
For each case,you have to output the case number first(Reference the sample).
If the answer is smaller than 0, you just need to output 0 as the answer.
If the answer’s format is 2^x,you need to output the x as the answer.
Output the answer in one line.
Sample Input
2
2
-2 0
10
2 2 0 -2 0 2 2 -2 -2 0
Sample Output
Case #1: 0
Case #2: 4
题目大意:给你一组数,这组数由0,-2,2组成。让你求出最大的连续积,然后输出它是2的多少次方,如果最大积为0 的话输出0。
思路:暴力扫。
下面是AC代码:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[10005];
int main()
{
int t,iCase=0;
scanf("%d",&t);
while(t--)
{
iCase++;
int n;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
int maxn=0,cnt,flag;
for(int i=0;i<n;i++)
{
if(a[i]==0)
{
continue;
}
cnt=0;
flag=0;
for(int j=i;j<n;j++)
{
if(a[j]==0)
{
break;
}
if(a[j]==2)
{
cnt++;
}
if(a[j]==-2)
{
flag=1-flag;
cnt++;
}
if(flag==0)
{
maxn=max(maxn,cnt);
}
}
}
printf("Case #%d: %d\n",iCase,maxn);
}
return 0;
}