HDU 2131 Probability

Probability

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5634    Accepted Submission(s): 2811


Problem Description
Mickey is interested in probability recently. One day , he played a game which is about probability with mini.First mickey gives a letter and a word to mini.Then mini calculate the probability that the letter appears in the word.For example,give you the letter "a" and the word "apple". the probability of this case is 0.20000.
 

Input
The input contains several test cases. Each test case consists of a letter and a word.The length of the word is no longer than 200.
 

Output
For each test case, print the probability rounded to five digits after the decimal point.
 

Sample Input
   
   
   
   
a apple c Candy a banana
 

Sample Output
   
   
   
   
0.20000 0.20000 0.50000
题目本质是统计该字符在字符串出现的次数,只要注意大小写算一个字符就可以了。

代码如下:

<span style="font-size:14px;">#include <stdio.h>
#include <string.h>
#include <math.h>
int main()
{
	char ch,str[205];
	int i,j;
	while(~scanf("%c %s%*c",&ch,str))
	{
		int len=strlen(str),index=0;
		for(i=0;i<len;i++)
			if(ch==str[i] || fabs(ch-str[i])==32)
				index++;
		double sum=index*1.0/len;
		printf("%.5lf\n",sum);
	}
	
	return 0;
}</span>



你可能感兴趣的:(HDU 2131 Probability)