An Easy Problem
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 5783 |
|
Accepted: 3344 |
Description
As we known, data stored in the computers is in binary form. The problem we discuss now is about the positive integers and its binary form.
Given a positive integer I, you task is to find out an integer J, which is the minimum integer greater than I, and the number of '1's in whose binary form is the same as that in the binary form of I.
For example, if "78" is given, we can write out its binary form, "1001110". This binary form has 4 '1's. The minimum integer, which is greater than "1001110" and also contains 4 '1's, is "1010011", i.e. "83", so you should output "83".
Input
One integer per line, which is I (1 <= I <= 1000000).
A line containing a number "0" terminates input, and this line need not be processed.
Output
One integer per line, which is J.
Sample Input
1
2
3
4
78
0
Sample Output
2
4
5
8
83
题目大意:求比比n大且离n最近的数,并且这个数的二进制于n二进制'1'位数相同
思路:暴力过的200多MS,这题我还有个方法,假设n的二进制为abcdefg..共S位,,,如果第i位为0并且i+1位为1
则将第i+1位的1移到第i位上来并且将i+1~S所有的1紧密排列在尾部,算出这个数的值,输出最小的就是结果,但
位运算没学过就没写。。。
暴力搜索的code......FUCK
#include<iostream>
using namespace std;
int l(int n)
{
int s=0;
while(n)
{
if(n%2)s++;
n/=2;
}
return s;
}
int main()
{
int n,s;
while(cin>>n&&n)
{
s=l(n);
while(1)
if(s==l(++n))
break;
cout<<n<<endl;
}
return 0;
}