hdu5019——Revenge of GCD

Revenge of GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 226    Accepted Submission(s): 66


Problem Description
In mathematics, the greatest common divisor (gcd), also known as the greatest common factor (gcf), highest common factor (hcf), or greatest common measure (gcm), of two or more integers (when at least one of them is not zero), is the largest positive integer that divides the numbers without a remainder.
---Wikipedia

Today, GCD takes revenge on you. You have to figure out the k-th GCD of X and Y.
 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case only contains three integers X, Y and K.

[Technical Specification]
1. 1 <= T <= 100
2. 1 <= X, Y, K <= 1 000 000 000 000
 

Output
For each test case, output the k-th GCD of X and Y. If no such integer exists, output -1.
 

Sample Input
   
   
   
   
3 2 3 1 2 3 2 8 16 3
 

Sample Output
   
   
   
   
1 -1 2
 

Source
BestCoder Round #10
 

Recommend
heyang   |   We have carefully selected several similar problems for you:   5021  5020  5018  5017  5016


第k大的gcd,就是gcd的第k大的因子
比赛时没优化好导致超时了

#include<map>
#include<set>
#include<list>
#include<stack>
#include<queue>
#include<vector>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

__int64 gcd(__int64 a, __int64 b)
{
    if(b == 0)
        return a;
    return gcd(b, a % b);
}

__int64 fac[100010];

int main()
{
    int t;
    __int64 a, b, c;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%I64d%I64d%I64d", &a, &b, &c);
        __int64 x = gcd(a, b);
        if(x == 1 && c > 1)
        {
            printf("-1\n");
            continue;
        }
        else if(c == 1)
        {
            printf("%I64d\n", x);
            continue;
        }
        else
        {
            __int64 sum = 1;
            __int64 cnt = 0;
            __int64 temp = sqrt((double)x + 1.0);
            for(__int64 i = 1; i <= temp; i++)
            {
    				if(x % i == 0)
    				{
				    	fac[cnt++] = i;
				    	fac[cnt++] = x / i;
				    }
            }
            sort(fac,fac + cnt);
            if(cnt < c)
            {
            	printf("-1\n");
            	continue;
            }
            printf("%I64d\n", fac[cnt - c]);
        }
    }
    return 0;
}


你可能感兴趣的:(hdu5019——Revenge of GCD)