HDOJ 2717 Catch That Cow(BFS)

Catch That Cow

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8896    Accepted Submission(s): 2806


Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
   
   
   
   
5 17
 

Sample Output
   
   
   
   
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 

ac代码:
#include<stdio.h>
#include<iostream>
#include<queue>
#include<algorithm>
#include<string.h>
using namespace std;
int n,m;
int dir[2]={1,-1};
int v[1000100];//一定要定义足够大
struct s
{
	int x;
	int step;
}a,b;
int check(int xx)
{
	if(xx<0||xx>=1000100||v[xx])//一定要把范围定义足够大,在两个范围问题上wrong了无数
	return 0;
	return 1;
}
int bfs(int w)
{
	int i;
	a.x=w;
	a.step=0;
	v[a.x]=1;
	queue<s>q;
	q.push(a);
	while(!q.empty())
	{
		a=q.front();
		q.pop();
		if(a.x==m)
		{
			return a.step;
		}
		for(i=0;i<2;i++)//检查 +1,-1两种情况 
		{
		   b=a;
		   b.x=a.x+dir[i];
		   if(check(b.x))
		   {
			   b.step=a.step+1;
			   v[b.x]=1;//标记 
			   q.push(b);
		   }
	    }
		b.x=a.x*2;//检查x2的情况 
		if(check(b.x))
		{
			b.step=a.step+1;
			v[b.x]=1;
			q.push(b);
		}
	}
	return 0;
}
int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(v,0,sizeof(v));
		int num;
		num=bfs(n);
		printf("%d\n",num);
	}
	return 0;
 } 



你可能感兴趣的:(HDOJ 2717 Catch That Cow(BFS))