POJ 2602 Superlong sums(模拟大数加法)

Superlong sums
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 22715   Accepted: 6709

Description

The creators of a new programming language D++ have found out that whatever limit for SuperLongInt type they make, sometimes programmers need to operate even larger numbers. A limit of 1000 digits is so small... You have to find the sum of two numbers with maximal size of 1.000.000 digits.

Input

The first line of an input file contains a single number N (1<=N<=1000000) - the length of the integers (in order to make their lengths equal, some leading zeroes can be added). It is followed by these integers written in columns. That is, the next N lines contain two digits each, divided by a space. Each of the two given integers is not less than 1, and the length of their sum does not exceed N.

Output

Output file should contain exactly N digits in a single line representing the sum of these two integers.

Sample Input

4
0 4
4 2
6 8
3 7

Sample Output

4750


注意用字符串输出可以加快输出的速度,不用字符串输出会TLE.


#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<map>
#include<algorithm>
#include<queue>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;
int a[1000010],b[1000010];
char s1[1000010],s[1000010];
int main()
{
    int n,m,i,j;
    scanf("%d",&n);
    memset(a,0,sizeof(a));
    memset(b,0,sizeof(b));
    for(i=1; i<=n;i++)
    {
        scanf("%d%d",a+i,b+i);
    }
    int l=0;
    for(i=n; i>=1; i--)
    {
        j=a[i]+b[i];
        if(j>=10)
        {
            s[l++]=(j%10)+'0';
            if(i>=2)
            b[i-1]+=1;
        }
        else
           s[l++]=j+'0';
    }
    int t=0;
    for(i=l-1;i>=0;i--)
    {
        s1[t++]=s[i];
    }
    s1[t]='\0';
    printf("%s\n",s1);
    return 0;
}



你可能感兴趣的:(串)