数学—杭电1425 sort

http://acm.hdu.edu.cn/showproblem.php?pid=1425

sort

Time Limit: 6000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25652    Accepted Submission(s): 7718

Problem Description
给你n个整数,请按从大到小的顺序输出其中前m大的数。
 
Input
每组测试数据有两行,第一行有两个数n,m(0<n,m<1000000),第二行包含n个各不相同,且都处于区间[-500000,500000]的整数。
 
Output
对每组测试数据按从大到小的顺序输出前m大的数。
 
Sample Input
   
   
   
   
5 3 3 -35 92 213 -644
 
Sample Output
   
   
   
   
213 92 3

 

 

#include<iostream>
#include<algorithm>
using namespace std;
bool cmp(int a,int b)
{
    return a > b;
}
int main()
{
    int n,m;
    while(cin>>n>>m)
    {  
        int i; 
        int* num = new int[n]; 
        for(i=0;i<n;i++)  
            scanf("%d",num+i);  
        sort(num,num+n,cmp);  
        for(i=0;i<m-1;i++) 
            printf("%d ",num[i]); 
        printf("%d\n",num[i]);  
        delete num; 
}
    return 0;
}


 

你可能感兴趣的:(数学—杭电1425 sort)