POJ2492——A Bug's Life

Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany

这题是在kuangbin 博客的并查集里看到的,但是当我看完这题,我第一反应是bfs染色,如果找到某条边的两端颜色相同就说明有同性恋


#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;

const int N=2000010;
const int maxn=2010;
int col[maxn];

struct node
{
	int next;
	int to;
}edge[N];
int head[maxn];
int tot;

void addedge(int from,int to)
{
	edge[tot].to=to;
	edge[tot].next=head[from];
	head[from]=tot++;
}

bool bfs(int root)
{
	queue<int>qu;
	while(!qu.empty())
		qu.pop();
	col[root]=1;
	qu.push(root);
	while(!qu.empty())
	{
		int u=qu.front();
		qu.pop();
		for(int i=head[u];i!=-1;i=edge[i].next)
		{
			int v=edge[i].to;
			if(col[v]==-1)
			{
				col[v]=(!col[u]);
				qu.push(v);
			}
			if(col[v]==col[u])
				return false; 
		}
	}
	return true;
}

int main()
{
	int t;
	scanf("%d",&t);
	int n,m,u,v;
	int icase=1;
	while(t--)
	{
		memset(head,-1,sizeof(head));
		memset(col,-1,sizeof(col));
		tot=0;
		scanf("%d%d",&n,&m);
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d",&u,&v);
			addedge(u,v);
			addedge(v,u);
		}
		bool flag;
		for(int i=1;i<=n;i++)
		{
			if(col[i]==-1)
			{
				flag=bfs(i);
				if(!flag)
					break;
			}
		}
		printf("Scenario #%d:\n",icase++);
		if(flag)
			printf("No suspicious bugs found!\n\n");
		else
			printf("Suspicious bugs found!\n\n");
	}
	return 0;
}


你可能感兴趣的:(POJ2492——A Bug's Life)