【杭电oj】1196 - Lowest Bit(位运算)

Lowest Bit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10324    Accepted Submission(s): 7564


Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.

For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.

Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.
 

Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.
 

Output
For each A in the input, output a line containing only its lowest bit.
 

Sample Input
   
   
   
   
26 88 0
 

Sample Output
   
   
   
   
2 8
 

Author
SHI, Xiaohan
 

Source
Zhejiang University Local Contest 2005 


简单位运算的题。

代码如下:

#include <stdio.h>
int main()
{
	int ans;
	int n;
	while (~scanf ("%d",&n) && n)
	{
		ans=1;
		while (!(n&1))		//n的二进制末尾是1时结束循环 
		{
			ans*=2;
			n>>=1;
		}
		printf ("%d\n",ans);
	}
	return 0;
}



你可能感兴趣的:(【杭电oj】1196 - Lowest Bit(位运算))