POJ 2828(线段树,思维,逆序数变形题)

Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 17510   Accepted: 8698

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Valiin the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

POJ 2828(线段树,思维,逆序数变形题)_第1张图片

Source

POJ Monthly--2006.05.28, Zhu, Zeyuan



题意:就是有n个人排队,每次有个人插队,使得这个人的前面只有x+1个人。



题解:开始完全没有思路,想了又想这和线段树根本没有关系呀!暴力模拟?查了题解,原来这一题需要倒着插入,插在前面只有x+1个人的那个位置,这里就明朗了,使用线段树维护区间和,每次插入恰好区间和为x+1的位置,这和复原逆序数非常的相似





#include<cstdio>  
#include<cstring>  
#include<cstdlib>  
#include<cmath>  
#include<iostream>  
#include<algorithm>  
#include<vector>  
#include<map>  
#include<set>  
#include<queue>  
#include<string>  
#include<bitset>  
#include<utility>  
#include<functional>  
#include<iomanip>  
#include<sstream>  
#include<ctime>  
using namespace std;

#define N int(2e5+10)  
#define inf int(0x3f3f3f3f)  
#define mod int(1e9+7)  
#define lson L,mid,rt<<1
#define rson mid+1,R,rt<<1|1
typedef long long LL;


#ifdef CDZSC  
#define debug(...) fprintf(stderr, __VA_ARGS__)  
#else  
#define debug(...)   
#endif  
pair<int, int>a[N];
struct segment
{
	int lc, rc, va, num;
	int mid() { return (lc + rc) >> 1; }
}tree[N << 2];
void pushup(int rt)
{
	tree[rt].va = tree[rt << 1].va + tree[rt << 1 | 1].va;
}
void build(int L, int R, int rt)
{
	tree[rt].lc = L;
	tree[rt].rc = R;
	if (R == L)
	{
		tree[rt].va = 1;
		return;
	}
	int mid = tree[rt].mid();
	build(lson);
	build(rson);
	pushup(rt);
}
void insert(int x, int rt, int val)
{
	if (tree[rt].lc == tree[rt].rc)
	{
		tree[rt].va = 0;
		tree[rt].num = val;
		return;
	}
	if (tree[rt << 1].va >= x)
		insert(x, rt << 1, val);
	else
		insert(x - tree[rt << 1].va, rt << 1 | 1, val);
	pushup(rt);
}
int query(int pos, int rt)
{
	if (tree[rt].lc == tree[rt].rc)
	{
		return tree[rt].num;
	}
	int mid = tree[rt].mid();
	if (pos <= mid)
		return  query(pos, rt << 1);
	else
		return query(pos, rt << 1 | 1);
}

int main()
{
#ifdef CDZSC  
	freopen("i.txt", "r", stdin);
	//freopen("o.txt","w",stdout);  
	int _time_jc = clock();
#endif  
	int n;
	while (~scanf("%d", &n))
	{
		build(1, n, 1);
		for (int i = 1; i <= n; i++)
			scanf("%d%d", &a[i].first, &a[i].second);
		for (int i = n; i >= 1; i--)
		{
			insert(a[i].first+1, 1, a[i].second);
		}
		for (int i = 1; i <= n; i++)
		{
			printf("%d%c", query(i, 1), i == n ? '\n' : ' ');
		}
	}
#ifdef CDZSC  
	debug("time: %d\n", int(clock() - _time_jc));
#endif  
	return 0;
}





你可能感兴趣的:(POJ 2828(线段树,思维,逆序数变形题))