UVA699 The Falling Leaves【二叉树】【递归】

  The Falling Leaves 

Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened to binary trees, how large would the piles of leaves become?

We assume each node in a binary tree "drops" a number of leaves equal to the integer value stored in that node. We also assume that these leaves drop vertically to the ground (thankfully, there's no wind to blow them around). Finally, we assume that the nodes are positioned horizontally in such a manner that the left and right children of a node are exactly one unit to the left and one unit to the right, respectively, of their parent. Consider the following tree:
The nodes containing 5 and 6 have the same horizontal position (with different vertical positions, of course). The node containing 7 is one unit to the left of those containing 5 and 6, and the node containing 3 is one unit to their right. When the "leaves" drop from these nodes, three piles are created: the leftmost one contains 7 leaves (from the leftmost node), the next contains 11 (from the nodes containing 5 and 6), and the rightmost pile contains 3. (While it is true that only leaf nodes in a tree would logically have leaves, we ignore that in this problem.)

Input 

The input contains multiple test cases, each describing a single tree. A tree is specified by giving the value in the root node, followed by the description of the left subtree, and then the description of the right subtree. If a subtree is empty, the value -1 is supplied. Thus the tree shown above is specified as 5 7 -1 6 -1 -1 3 -1 -1. Each actual tree node contains a positive, non-zero value. The last test case is followed by a single -1 (which would otherwise represent an empty tree).


Output 

For each test case, display the case number (they are numbered sequentially, starting with 1) on a line by itself. On the next line display the number of "leaves" in each pile, from left to right, with a single space separating each value. This display must start in column 1, and will not exceed the width of an 80-character line. Follow the output for each case by a blank line. This format is illustrated in the examples below.


Sample Input 

5 7 -1 6 -1 -1 3 -1 -1
8 2 9 -1 -1 6 5 -1 -1 12 -1
-1 3 7 -1 -1 -1

-1


Sample Output 


Case 1:
7 11 3


Case 2:

9 7 21 15


题目大意:给你一棵二叉树,每个节点都有一个位置。左子结点在它左边1个单位,

右子节点在它右边1个单位。在竖直方向上在一条线上的点位置相同。比如图中的5

和6在同一位置。现在从左到右,输出这棵树上相同位置上的所有节点的和。

思路:最多80个叶子节点,那么算上每层节点不会多于160个。建一个200左右的数

组,让中间编号为根结点,递归建立左右子树。并将相同位置的和累加。


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

int sum[220];
void build(int p)
{
    int v;
    cin >> v;
    if(v == -1)
        return;
    sum[p] += v;
    build(p-1);
    build(p+1);
}
bool init()
{
    int v;
    cin >> v;
    if(v == -1)
        return false;
    memset(sum,0,sizeof(sum));
    int p = 200>>1;//根结点在最中间,向两边建立二叉树
    sum[p] = v;
    build(p-1);//左子树
    build(p+1);//右子树

}

int main()
{
    int kase = 0;
    while(init())
    {
        int p = 0;
        while(sum[p]==0)
            p++;
        cout << "Case " << ++kase << ":" << endl << sum[p++];
        while(sum[p]!=0)
            cout << " " << sum[p++];
        cout << endl << endl;
    }
    return 0;
}



你可能感兴趣的:(UVA699 The Falling Leaves【二叉树】【递归】)