B - Falling Leaves(10.1.2))

B - Falling Leaves(10.1.2))
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

B - Falling Leaves(10.1.2))_第1张图片 
Figure 1
Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem. 

A binary tree of letters may be one of two things: 
  1. It may be empty. 
  2. It may have a root node. A node has a letter as data and refers to a left and a right subtree. The left and right subtrees are also binary trees of letters.

In the graphical representation of a binary tree of letters: 
  1. Empty trees are omitted completely. 
  2. Each node is indicated by 
    • Its letter data, 
    • A line segment down to the left to the left subtree, if the left subtree is nonempty, 
    • A line segment down to the right to the right subtree, if the right subtree is nonempty.

A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y. 

The preorder traversal of a tree of letters satisfies the defining properties: 
  1. If the tree is empty, then the preorder traversal is empty. 
  2. If the tree is not empty, then the preorder traversal consists of the following, in order 
    • The data from the root node, 
    • The preorder traversal of the root's left subtree, 
    • The preorder traversal of the root's right subtree.

The preorder traversal of the tree in Figure 1 is KGCBDHQMPY. 

A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies: 

The root's data comes later in the alphabet than all the data in the nodes in the left subtree. 

The root's data comes earlier in the alphabet than all the data in the nodes in the right subtree. 

The problem: 

Consider the following sequence of operations on a binary search tree of letters 

Remove the leaves and list the data removed 
Repeat this procedure until the tree is empty 
Starting from the tree below on the left, we produce the sequence of trees shown, and then the empty tree 
B - Falling Leaves(10.1.2))_第2张图片
by removing the leaves with data 

BDHPY 
CM 
GQ 


Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree.

Input

The input will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters. 

The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk ('*'). 

The last data set is followed by a line containing only a dollar sign ('$'). There are no blanks or empty lines in the input

Output

For each input data set, there is a unique binary search tree that would produce the sequence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.

Sample Input

BDHPY
CM
GQ
K
*
AC
B
$
Sample Output

KGCBDHQMPY
BAC
题目大意:删除树叶,并将被删除的树叶列出,重复这一过程直到树叶为空。给出删除顺序,求树的前序遍历。
解题思路:根据删除叶子的顺序,建立二叉搜索树,然后前序遍历输出即可。
根据删除的序列表可以知道最后一个删除的一定是根节点,倒着搜索,比根节点小的放在左子树上,大的放在右子树上。依次递归建树。最后前根遍历输出。
代码:
#include <iostream>
#include <cstring>
using namespace std;
typedef struct node
{
    char ch;
    node *left;
    node *right;
}*Node,node;
Node head=NULL;
char s[300][30000];
void creat(Node &h,char v)
{
    if(h==NULL)
    {
        h=new node;
        h->left=NULL;
        h->right=NULL;
        h->ch=v;
    }
    else
        {
            if(h->ch>v)
           {
              creat(h->left,v);
           }
           else
            creat(h->right,v);
        }

}
void print(Node head)
{
    if(head!=NULL)
    cout<<head->ch;
    if(head->left!=NULL)
    print(head->left);
    if(head->right!=NULL)
    print(head->right);
}
int main()
{
    int i,j,n=0;
    while(1)
    {
        int p;
        for(p=0;;p++)
        {
            cin>>s[p];
            if(s[p][0]=='*'||s[p][0]=='$')
                break;
        }
        for(i=p-1;i>=0;i--)
        {
            for(j=0;s[i][j];j++)
                creat(head,s[i][j]);
        }

        print(head);
        cout<<endl;
        if(s[p][0]=='$')
            break;
         head=NULL;

    }
    return 0;
}


 
   

你可能感兴趣的:(B - Falling Leaves(10.1.2)))