HDU2817:A sequence of numbers(快速幂取模)

Problem Description
Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.
 

Input
The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.
 

Output
Output one line for each test case, that is, the K-th number module (%) 200907.
 

Sample Input
   
   
   
   
2 1 2 3 5 1 2 4 5
 

Sample Output
   
   
   
   
5 16


 

题意,给出一个数列的前三个数,根据这三个数字可以得出这个数列是等差还是等比数列,再求出数列的第K个数,不过要注意的是由于数字很大,所以要用到快速幂取模

 

#include<stdio.h>
#include<string.h>
#include <algorithm>
using namespace std;
#define MOD 200907

__int64 quickmod(__int64 a,__int64 b,__int64 n)
{
    __int64 ret=1;
    for (; b; b>>=1,a=(__int64)(((__int64)a)*a%n))
        if (b&1)
            ret=(__int64)(((__int64)ret)*a%n);
    return ret;
}


int main()
{
    double a,b,c;
    int T;
    int k;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf%lf%d",&a,&b,&c,&k);
        if(a+c==2*b)
        {
            __int64 a1=(__int64 )a;
            __int64 d=(__int64 )(b-a);
            int ans=(a1%MOD+((k-1)%MOD)*(d%MOD))%MOD;
            printf("%d\n",ans);
        }
        else
        {
            __int64 a1=(__int64)a;
            __int64 t1=(__int64)(a1%MOD);
            double q1=(b/a);
            __int64 q2=(__int64)q1;
            __int64 q=(__int64)(q2%MOD);
            __int64 tmp=quickmod(q,k-1,MOD);
            int ans=(t1*tmp)%MOD;


            printf("%d\n",ans);
        }
    }
    return 0;
}


 

你可能感兴趣的:(HDU,快速幂取模)