LightOJ 1043 - Triangle Partitioning【数学】

 

LightOJ 1043 - Triangle Partitioning

Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit  Status  Practice  LightOJ 1043

Description

See the picture below.

LightOJ 1043 - Triangle Partitioning【数学】_第1张图片

You are given ABAC and BCDE is parallel to BC. You are also given the area ratio between ADE and BDEC. You have to find the value of AD.

Input

Input starts with an integer T (≤ 25), denoting the number of test cases.

Each case begins with four real numbers denoting AB, AC, BC and the ratio of ADE and BDEC(ADE / BDEC). You can safely assume that the given triangle is a valid triangle with positive area.

Output

For each case of input you have to print the case number and AD. Errors less than 10-6 will be ignored.

Sample Input

4

100 100 100 2

10 12 14 1

7 8 9 10

8.134 9.098 7.123 5.10

Sample Output

Case 1: 81.6496580

Case 2: 7.07106781

Case 3: 6.6742381247

Case 4: 7.437454786

AC-code: 

#include<cstdio>
#include<cmath>
int main()
{
	int T,i;
	double ans,a,b,c,d;
	scanf("%d",&T);
	for(i=1;i<=T;i++)
	{
		scanf("%lf%lf%lf%lf",&a,&b,&c,&d);
		ans=a/sqrt((d+1)/d);
		printf("Case %d: %.7lf\n",i,ans);
	}
	return 0;
}


你可能感兴趣的:(数学,lightoj)