http://poj.org/problem?id=2230
Description
Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done.
If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice.
A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.
Input
* Line 1: Two integers, N and M.
* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.
Output
* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.
Sample Input
4 5
1 2
1 4
2 3
2 4
3 4
Sample Output
1
2
3
4
2
1
4
3
2
4
1
在深度优先搜索的过程中每次只标记经过边的单方向,并记录遍历点的终点,回溯过程中输出被标记的点得出的就是每条边走过两次的欧拉回路。
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int t;
int ip,head[10005];
struct note
{
int to;
int next;
bool vis;
};
note edge[100004];
void add(int u,int v)
{
edge[ip].to=v;edge[ip].next=head[u];head[u]=ip++;
}
void dfs(int x)
{
for(int k=head[x];k!=-1;k=edge[k].next)
{
if(!edge[k].vis)
{
edge[k].vis=true;
dfs(edge[k].to);
printf("%d\n",edge[k].to);
}
}
}
int main()
{
int m,n,u,v;
while(~scanf("%d%d",&n,&m))
{
t=0;
memset(head,-1,sizeof(head));
ip=0;
for(int i=0;i<m;i++)
{
scanf("%d%d",&u,&v);
add(u,v);
add(v,u);
}
dfs(1);
printf("1\n");
}
return 0;
}