HDU 5533:Dancing Stars on Me【数学】

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 634    Accepted Submission(s): 336


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n , denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi , describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
   
   
   
   
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
   
   
   
   
NO YES NO
 因为坐标都为整数,且要求为正多边形,所以n必须为4.。。
AC-code:
#include<cstdio>
#include<cmath>
int x[105],y[105];
float dis(int i,int j)
{
	return sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
}
int main()
{
	int T,n,flag,i,j;
	float min,a;
	scanf("%d",&T);
	while(T--)
	{
		flag=0;
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d%d",&x[i],&y[i]);
		if(n!=4)
		{
			printf("NO\n");
			continue;
		}
				min=20010;
			for(j=1;j<n;j++)
			{
				a=dis(0,j);
				if(a<min)
					min=a;
			}
		for(i=0;i<n;i++)
			for(j=i+1;j<n;j++)
			{
				if(dis(i,j)==min)
					flag++;
			}
		if(flag==n)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}


你可能感兴趣的:(数学,HDU,细心)