HDU 1879 继续畅通工程

Description

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。

当N为0时输入结束。
 

Output

每个测试用例的输出占一行,输出全省畅通需要的最低成本。
 

Sample Input

     
     
     
     
3 1 2 1 0 1 3 2 0 2 3 4 0 3 1 2 1 0 1 3 2 0 2 3 4 1 3 1 2 1 0 1 3 2 1 2 3 4 1 0
 

Sample Output

     
     
     
     
3 1 0
对于这道题,我无话可说,题目几乎和前面一样,就只是改了一句话 if(bo)w=0;
language:c++
code:
#include<iostream>
#include<cstdio>
#include<vector>
#include<queue>
using namespace std;

struct node
{
    int u,v,w,bo;
    node(int x,int y,int z,int q):u(x),v(y),w(z),bo(q){}
    bool operator <(const node a)const
    {
        return w>a.w;
    }
};

int rank[105],father[105];

void set(int x)
{
    rank[x]=0;
    father[x]=x;
}

int find(int x)
{
    if(x!=father[x])
        father[x]=find(father[x]);
    return father[x];
}

bool merge(int u,int v)
{
    int x=find(u);
    int y=find(v);
    if(x!=y)
    {
        if(rank[x]>rank[y])
        {
            father[y]=x;
        }
        else
        {
            if(rank[x]==rank[y])
            {
                rank[y]++;
            }
            father[x]=y;
        }
        return true;
    }
    return false;
}

int main()
{
    //freopen("in.txt","r",stdin);
    int n;
    int u,v,w,bo,ans;
    while(scanf("%d",&n))
    {
        if(n==0)break;
        ans=0;
        priority_queue<node>prique;
        n=n*(n-1)>>1;
        while(n--)
        {
            scanf("%d%d%d%d",&u,&v,&w,&bo);
            if(bo)w=0;
            prique.push(node(u,v,w,bo));
            set(u),set(v);
        }
        while(!prique.empty())
        {
            if(merge(prique.top().u,prique.top().v))
                ans+=prique.top().w;
            prique.pop();
        }
        printf("%d\n",ans);
    }
    return 0;
}


你可能感兴趣的:(HDU 1879 继续畅通工程)