red放到后面显然更优,dp【i】【j】表示前i个塔里有j个blue,最后枚举有多少个red
Stupid Tower Defense
Time Limit: 12000/6000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 599 Accepted Submission(s): 163
Problem Description
FSF is addicted to a stupid tower defense game. The goal of tower defense games is to try to stop enemies from crossing a map by building traps to slow them down and towers which shoot at them as they pass.
The map is a line, which has n unit length. We can build only one tower on each unit length. The enemy takes t seconds on each unit length. And there are 3 kinds of tower in this game: The red tower, the green tower and the blue tower.
The red tower damage on the enemy x points per second when he passes through the tower.
The green tower damage on the enemy y points per second after he passes through the tower.
The blue tower let the enemy go slower than before (that is, the enemy takes more z second to pass an unit length, also, after he passes through the tower.)
Of course, if you are already pass through m green towers, you should have got m*y damage per second. The same, if you are already pass through k blue towers, the enemy should have took t + k*z seconds every unit length.
FSF now wants to know the maximum damage the enemy can get.
Input
There are multiply test cases.
The first line contains an integer T (T<=100), indicates the number of cases.
Each test only contain 5 integers n, x, y, z, t (2<=n<=1500,0<=x, y, z<=60000,1<=t<=3)
Output
For each case, you should output "Case #C: " first, where C indicates the case number and counts from 1. Then output the answer. For each test only one line which have one integer, the answer to this question.
Sample Input
Sample Output
Case #1: 12
Hint
For the first sample, the first tower is blue tower, and the second is red tower. So, the total damage is 4*(1+2)=12 damage points.
Author
UESTC
Source
2014 Multi-University Training Contest 7
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long int LL;
LL n,x,y,z,t;
LL dp[1600][1600];
int main()
{
int T_T,cas=1;
scanf("%d",&T_T);
while(T_T--)
{
cin>>n>>x>>y>>z>>t;
LL ans=0;
memset(dp,0,sizeof(dp));
for(LL i=2;i<=n;i++)
{
for(LL blue=0;blue<i;blue++)
{
if(blue)
{
dp[i][blue]=max(dp[i-1][blue]+(t+blue*z)*(i-blue-1)*y
,dp[i-1][blue-1]+(t+(blue-1)*z)*(i-blue)*y);
}
else
{
dp[i][0]=dp[i-1][0]+t*(i-1)*y;
}
}
}
for(LL red=0;red<=n;red++)
{
for(LL blue=0;blue<=n-red;blue++)
{
LL green=n-red-blue;
ans=max(ans,red*(x+green*y)*(blue*z+t)+dp[n-red][blue]);
}
}
printf("Case #%d: %I64d\n",cas++,ans);
}
return 0;
}