HDOJ题目地址:传送门
The Center of Gravity
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5487 Accepted Submission(s): 3129
Problem Description
Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked
leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then
on,people have sovled many problems by the the theory of the Universal Gravitation. What's more, wo also
have known every object has its Center of Gravity.
Now,you have been given the coordinates of three points of a triangle. Can you calculate the center
of gravity of the triangle?
Input
The first line is an integer n,which is the number of test cases.
Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.
The input is terminated by n = 0.
Output
For each case, print the coordinate, accurate up to 1 decimal places.
Sample Input
2
1.0 2.0 3.0 4.0 5.0 2.0
1.0 1.0 4.0 1.0 1.0 5.0
0
Sample Output
题解:就是求三角形的重心,但是这个题目要注意下一键盘录入。
#include<iostream>
#include<stdio.h>
using namespace std;
int main(){
int n;
double x1,x2,x3,y1,y2,y3;
while(cin>>n){
if(n==0)
break;
while(n--){
cin>>x1>>y1>>x2>>y2>>x3>>y3;
printf("%.1lf %.1lf\n",(x1+x2+x3)/3,(y1+y2+y3)/3);
}
}
return 0;
}