HDU-1789 Doing Homework again

HDU-1789 Doing Homework again

            Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output
For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output
0
3
5

题目思路:贪心,先给分数从大到小排序,再开一个数组标记该天是否访问过,如果访问过,往前推一天。

题目链接:HDU 1789

以下是代码:

#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;
struct node
{
    int d,r;    
}s[2000];
bool cmp(node a,node b)
{
    if (a.r != b.r)
        return a.r > b.r;
    else
        return a.d < b.d;
}
int main(){
    int t;
    cin >> t;
    while(t--)
    {
        int n;
        cin >> n;
        for (int i = 0; i < n; i++)
        {
            cin >> s[i].d;
        }
        for (int i = 0; i < n; i++)
        {
            cin >> s[i].r;
        }
        sort(s,s + n,cmp);
        int success = 0;
        int sum = 0;
        int cnt[10000] = {0};
        for (int i = 0; i < n; i++)
        {
            if (cnt[s[i].d] == 0)
            {
                cnt[s[i].d] = 1;
            }
            else
            {
                int flag = 1;
                while(cnt[s[i].d])
                {
                    s[i].d--;
                    if (s[i].d == 0)
                    {
                        flag = 0;
                        break;
                    }
                }
                if (!flag)
                {
                    sum += s[i].r;
                }
                if (cnt[s[i].d] == 0)
                    cnt[s[i].d] = 1;

            }           
        }
        cout << sum << endl;
    }
    return 0;
}

你可能感兴趣的:(HDU-1789 Doing Homework again)