poj3041--Asteroids(二分匹配)

Asteroids
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14324   Accepted: 7787

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X. 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

USACO 2005 November Gold
题目大意,给出n*n的矩阵,其中有m个流星,一下给出每颗流星的坐标,每一次攻击可以消除一行或一列的流星,问最少攻击几次?
竟然是二分匹配!竟然是二分匹配!竟然是二分匹配!竟然是二分匹配!
建图,以行为左点集,列为右点集,连线代表该点存在流星,做出二分匹配,题目转化为求解最小覆盖点 = 最大匹配数
#include <stdio.h>
#include <string.h>
struct node{
    int v ;
    node *next ;
} *head[600];
int temp[600] , link[600];
int f(int u)
{
    for(node *q = head[u] ; q != NULL ; q = q->next)
    {
        int k = q->v ;
        if( temp[k] ==0 )
        {
            temp[k] = 1;
            if( link[k] == -1 || f( link[k] ) )
            {
                link[k] = u ;
                return 1 ;
            }
        }
    }
    return 0 ;
}
int main()
{
    int i , j , n , m , ans ;
    while(scanf("%d %d", &n, &m)!=EOF)
    {
        memset(head,NULL,sizeof(head));
        memset(link,-1,sizeof(link));
        ans = 0 ;
        while(m--)
        {
            scanf("%d %d", &i, &j);
            node *q = new node ;
            q->v = i ;
            q->next = head[j] ;
            head[j] = q ;
        }
        for(i = 1 ; i <= n ; i++)
        {
            memset(temp,0,sizeof(temp));
            if( f(i) )
                ans++ ;
        }
        printf("%d\n", ans);
    }
    return 0;
}


你可能感兴趣的:(poj3041--Asteroids(二分匹配))