完全背包——POJ 2063

对应POJ 题目:点击打开链接

Investment
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
Submit  Status  Practice  POJ 2063

Description

John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. 
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him. 
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. 
Assume the following bonds are available: 
Value Annual
interest
4000
3000
400
250

With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200. 
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow. 
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). 
The following line contains a single number: the number d (1 <= d <= 10) of available bonds. 
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050

题意:有本金S,和N种股票,每种股票需要Ci的价格,收益为Vi,问t年后本息和最大为多少。如例子:


第一年:2 * 3000 + 1 * 4000 = 10000 为最佳选择,收益为900,总和为10900

第二年:2 * 3000 + 1 * 4000 = 10000 为最佳选择,收益为900,总和为11800

第三年:1 * 3000 + 2 * 4000 = 11000 为最佳选择,收益为1050,总和为12850

第四年:0 * 3000 + 3 * 4000 = 12000 为最佳选择,收益为1200,总和为14050


思路:每一年都在总金额内选择价值最大的股票,每种股票可以选任意多次,典型的完全背包问题,题目说代价Ci为1000的倍数,故每个代价可以除以1000减少空间消耗,相应总价也除以1000。


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define M 100000
#define N 25
#define MAX(x, y) ((x) > (y) ? (x) : (y))
int dp[M];
int c[N];
int v[N];

int main()
{
	//freopen("in.txt", "r", stdin);
	int T, n, money, year;
	int i, j, k, t, tmp;
	scanf("%d\n", &T);
	while(T--)
	{
		scanf("%d%d\n", &money, &year);
		scanf("%d\n", &n);
		for(i=1; i<=n; i++){
			scanf("%d%d\n", &c[i], &v[i]);
			c[i] /= 1000;
		}
		for(t=0; t<year; t++){
			memset(dp, 0, sizeof(dp));
			tmp = money / 1000;
			for(i=1; i<=n; i++){
				for(j=c[i]; j<=tmp; j++){
					dp[j] = MAX(dp[j-c[i]] + v[i], dp[j]);
				}
			}
			money += dp[tmp];
		}
		printf("%d\n", money);
	}
	return 0;
}






你可能感兴趣的:(完全背包——POJ 2063)