201412021749-hd-Octorber 21st

Octorber 21st

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3052    Accepted Submission(s): 1882


Problem Description
HDU's 50th birthday, on Octorber 21st, is coming. What an exciting day!! As a student of HDU, I always want to know how many days are there between today and Octorber 21st.So, write a problem and tell me the answer.Of course, the date I give you is always in 2006.

201412021749-hd-Octorber 21st_第1张图片

 

Input
The input consists of T test cases. The number of T is given on the first line of the input file.Following T lines, which represent dates, one date per line. The format for a date is "month day" where month is a number between 1 (which indicates January) and 12 (which indicates December), day is a number between 1 and 31.All the date in the input are in 2006, you can assume that all the dates in the input are legal(合法).
 

Output
For each case, if the date is before Octorber 21st, you should print a number that between the date and Octorber 21st.If the day is beyond Octorber 21st, just print "What a pity, it has passed!".If the date is just Octorber 21st, print"It's today!!".
 

Sample Input
   
   
   
   
7
10 20
10 19
10 21
10 1 9 1
12 12
11 11
 

Sample Output
   
   
   
   
1
2
20
It's today!!
50
What a pity, it has passed!
What a pity, it has passed!
 题目大意
        给定一个2006年中的任意一天,然后与10.21进行比较,如果在其之前则输出还差几天,否则的话输出相应的英文短句。
解题思路
       必须先存好每个月的天数啊,然后进行判断,如果是在其之前的话,直接加月份的话,就从month+1到9.
代码
#include<stdio.h>
int a[15];
int month,day;
void num()
{
	int i,j;
	for(i=1;i<=12;i++)
	{
		if(i==1||i==3||i==5||i==7||i==8||i==10||i==12)
		    a[i]=31;
		else if(i==4||i==6||i==9||i==11)
		    a[i]=30;
		else if(i==2)
		    a[i]=28;
	} 
}
int sum()
{
	num();
	int i,j,k;
	int sumday;
	if(month>10)
	    sumday=-1;
	else if(month==10)
	{
		if(day>21)
		    sumday=-1;
		else if(day==21)
		    sumday=0;
		else if(day<21)
		    sumday=21-day;
	}
	else if(month<10)
	{
		sumday=a[month]-day;
		for(i=month+1;i<10;i++)//直接加月份的话,从month+1到9 
		    sumday+=a[i];
		sumday+=21;
	}
	return sumday;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&month,&day);
		if(sum()==-1)
		    printf("What a pity, it has passed!\n");
		else if(sum()==0)
		    printf("It's today!!\n");
		else 
		    printf("%d\n",sum());
	}
	return 0;
} 



你可能感兴趣的:(201412021749-hd-Octorber 21st)