Zipper 深搜与剪枝

Problem Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete


As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee


Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
 

Input
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.
 

Output
For each data set, print: Data set n: yes if the third string can be formed from the first two, or Data set n: no if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
 

Sample Input
   
   
   
   
3 cat tree tcraete cat tree catrtee cat tree cttaree
 

Sample Output
   
   
   
   
Data set 1: yes Data set 2: yes

Data set 3: no

思路:DFS,但需要剪枝,可以节省很多时间,若不剪枝,1000MS超时,剪枝后78MS

#include<stdio.h>
char a[201],b[201],c[402];
int visit[201][201]={0};
int  isOk=0;
void dfs(int i,int j,int k)
{	/*if(visit[i][j]==1) return;*/
	if(c[k]=='\0')
	{	isOk=1;	return;	}
	if(a[i]!='\0'&&c[k]==a[i])
		dfs(i+1,j,k+1);
	if(b[j]!='\0'&&c[k]==b[j])
		dfs(i,j+1,k+1);
	visit[i][j]=1;
}

int main()
{	int n,i,j,cnt=0;
	scanf("%d",&n);
	while(n--)
	{	isOk=0;
		/*for(i=0;i<201;i++)
			for(j=0;j<201;j++)
				visit[i][j]=0;*/
		scanf("%s%s%s",a,b,c);
		dfs(0,0,0);
        printf("Data set %d: %s\n",++cnt,isOk?"yes":"no");
	}
	return 0;
}
//注释掉的即为剪枝内容


你可能感兴趣的:(Zipper 深搜与剪枝)