POJ ACM习题【No.3438】

Look and Say
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 3802 Accepted: 2379

Description

The look and say sequence is defined as follows. Start with any string of digits as the first element in the sequence. Each subsequent element is defined from the previous one by "verbally" describing the previous element. For example, the string 122344111 can be described as "one 1, two 2's, one 3, two 4's, three 1's". Therefore, the element that comes after 122344111 in the sequence is 1122132431. Similarly, the string 101 comes after 1111111111. Notice that it is generally not possible to uniquely identify the previous element of a particular element. For example, a string of 112213243 1's also yields 1122132431 as the next element.

Input

The input consists of a number of cases. The first line gives the number of cases to follow. Each case consists of a line of up to 1000 digits.

Output

For each test case, print the string that follows the given string.

Sample Input

3
122344111
1111111111
12345

Sample Output

1122132431
101
1112131415

 

这道题求解是需要注意:

1.单个数字的情况

2.最后数字为重复的情况

 

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		int num = Integer.valueOf(cin.nextLine()).intValue();
		String rawStr = null;
		
		
		char repeatChar = '\n';
		int repeat = 0;
		char temp = '\n';
		int newLineFlag = 0;
		
		for(int i = 0; i < num; i++)
		{
			newLineFlag = 0;
			StringBuffer sb = new StringBuffer();
			boolean oneLetter = false;
			rawStr = cin.nextLine();
			
			for(int j = 0; j < rawStr.length(); j++)
			{
				temp = rawStr.charAt(j);
				if(newLineFlag == 0)
				{
					repeatChar = temp;
					repeat = 1;
					newLineFlag = 1;
					if(j == rawStr.length()-1)
						oneLetter = true;
					continue;
				}
				
				if(temp == repeatChar)
				{
					repeat++;
				}else
				{
					sb.append(repeat);
					sb.append(repeatChar);
					repeatChar = temp;
					repeat = 1;
				}	
				
				if(j == rawStr.length()-1)
				{
					sb.append(repeat);
					sb.append(repeatChar);
				}
			}
			
			if(oneLetter == true)
			{
				System.out.println("1" + temp);
			}else
			{
				System.out.println(sb.toString());	
			}
			
		}

	}

}
 

 

 

 

你可能感兴趣的:(J#,UP)