C - Play a game

New Year is Coming!
ailyanlu is very happy today! and he is playing a chessboard game with 8600.
The size of the chessboard is n*n. A stone is placed in a corner square. They play alternatively with 8600 having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can’t make a move will lose the game. If both play perfectly, who will win the game?

Input
The input is a sequence of positive integers each in a separate line.
The integers are between 1 and 10000, inclusive,(means 1 <= n <= 10000) indicating the size of the chessboard. The end of the input is indicated by a zero.

Output
Output the winner (“8600” or “ailyanlu”) for each input line except the last zero.
No other characters should be inserted in the output.
Sample Input
2
0
Sample Output
8600

题意: 给出一个n*n的棋盘,其中有一个石头在角落,玩家通过移动石头来访问未访问的位置,谁不采取行动,谁就输了,先手8600.

题解:给出n * n的棋盘,要-1,因为石头占一个位置,res=n*n,如果res%2==0 ‘ailyanlu’赢
否则‘8600’赢

#include<iostream>
using namespace std;
int main(int argc, char const *argv[]) {
  int n;
  while (~scanf("%d",&n)&&n!=0) {
    int sum=n*n-1;
    if(sum%2==0) puts("ailyanlu");
    else puts("8600");
  }
  return 0;
}

你可能感兴趣的:(博弈论)