笔试题 非递减序列和HASH表最大桶深

2019.04.16 360企业安全笔试题

没什么难度,贴下问题记录下来

非递减序列
时间限制:C/C++语言 1000MS;其他语言 3000MS
内存限制:C/C++语言 65536KB;其他语言 589824KB
题目描述:
给出一个有n(0 < n <= 10000)个整数的数组A(-10000 <= Ai <=10000) , 请问是否可以至多修改一个元素, 使这个数组成为非递减数组。

输入
单个测试用例可能包含多行

每行包含一段整数ai,  0

输出
Yes或者No(大小写敏感)


样例输入
1 2 3 4
样例输出
Yes

提示
输入样例2
4 2 1
4 2 3

输出样例2
No
Yes

HASH表最大桶深
时间限制:C/C++语言 1000MS;其他语言 3000MS
内存限制:C/C++语言 131072KB;其他语言 655360KB
题目描述:
构建HASH表,HASH表大小为hashsize,键值key为正整数,hash函数表达为key%hashsize,求解最大桶深和对应等于该桶深的所有桶的索引值及桶中key值

输入
输入为

hashsize/key

格式,其中hashsize为正整数,key值可以是单个数字,数字区间等(如果key值重复的话要进行去重处理)

输出
输出为

maxdepth-index-key

(如果bucket有多个重复的值,输出第一个即可)

(key多个时,使用空格分隔)


样例输入
4/1-20,100
样例输出
6-0-100 20 16 12 8 4


时间几乎花在处理这个讨厌的输入格式上了 ,代码拙劣随便看看

import java.util.*;

public class Solution {
	public static void main(String[] args){
		Solution s = new Solution();		
		Scanner sc = new Scanner(System.in);
		String[] ex = new String[100];
		int count = 0;
		while(sc.hasNextLine()){
			String t = sc.nextLine();
			if(t == "" || t.equals("")){
				break;
			}
			ex[count++] = t;
		}
		for(int i=0; i set = new HashSet();
		for(int i=0; i < nums.length; i++){
			if(nums[i].indexOf("-") == -1){
				set.add(Integer.valueOf(nums[i]));
			}else{
				String[] tmp = nums[i].split("-");
				int start = Integer.valueOf(tmp[0]);
				int end = Integer.valueOf(tmp[1]);
				for(int j=start; j<=end; j++){
					set.add(j);
				}
			}
		}
		
		List> r = new LinkedList>();
		for(int i=0; i l = new LinkedList();
			r.add(l);
		}
		
		Iterator it = set.iterator();  
		while (it.hasNext()) {  
		  Integer str = it.next();  
		  int idx = str % hashsize;
		  r.get(idx).add(str);
		} 
		
		int max = 0;
		int idx = 0;
		for(int i=0; i max){
				max = r.get(i).size();
				idx = i;
			}
		}
		
		System.out.print(max+"-"+idx+"-");
		int size = r.get(idx).size();
		Collections.sort(r.get(idx), new Comparator() {
            public int compare(Integer o1, Integer o2) {
                return o2 - o1;
            }
        });
		for(int i=0; i nums[i]){
				times++;
				if(times > 1){
					System.out.println("No");
					return ;
				}
			}
		}
		System.out.println("Yes");
	}

}

 

你可能感兴趣的:(算法题)