多校7.21A——维护技巧——OO’s Sequence

Problem Description
OO has got a array A of size n ,defined a function f(l,r) represent the number of i (l<=i<=r) , that there's no j(l<=j<=r,j<>i) satisfy a i mod a j=0,now OO want to know
i=1nj=inf(i,j) mod 109+7.
 

 

Input
There are multiple test cases. Please process till EOF.
In each test case: 
First line: an integer n(n<=10^5) indicating the size of array
Second line:contain n numbers a i(0<a i<=10000)
 

 

Output
For each tests: ouput a line contain a number ans.
 

 

Sample Input
5 1 2 3 4 5
 

 

Sample Output
23
 

 

Source
 

 

Recommend
We have carefully selected several similar problems for you:   5299  5298  5297  5296  5295 
/*

 题意:对于所有的子区间找a[i]在这个区间没有因子的所有的情况

 对于一个数a[i]它的价值是L[i]:从左往右最接近的因子的下标,R[[i]:从右往左最接近的因子下标,a[i]在这个区间内都是可以的那么总共的种类区间有(i - L[i]) * (R[i] - i)

总复杂度O(n根号n)

用index数组来记录该因子出现的位置

*/

#include <cstdio>

#include <cstring>

#include <algorithm>

#include <cmath>

using namespace std;



const int MAX = 100000 + 10;

const int mod = 1e9 + 7;

int a[MAX];

int L[MAX], R[MAX], index[MAX];



int main()

{

    int n;

    while(~scanf("%d", &n)){

        for(int i = 1; i <= n; i++)

            scanf("%d", &a[i]);

        memset(index, -1, sizeof(index));

        for(int i = 1; i <= n; i++){

            int temp = sqrt(1.0 * a[i]);

            int l = 0;

            for(int j = 1; j <= temp; j++){

                if(a[i] % j == 0){

                    if(index[j] != -1) 

                        l = max(index[j], l);

                    if(index[a[i] / j] != -1)

                        l = max(index[a[i] / j], l);

                }

            }

                index[a[i]] = i;

                L[i] = l;

        }

        memset(index, -1, sizeof(index));

            for(int i = n; i >= 1 ;i--){

                int temp = sqrt(1.0 * a[i]);

                int r = n + 1;

                for(int j = 1; j <= temp; j++){

                    if(a[i] % j == 0){

                        if(index[j] != -1)

                            r = min(index[j], r);

                        if(index[a[i] / j] != -1)

                            r = min(index[a[i] / j], r);

                    }

                }

                index[a[i]] = i;

                R[i] = r;

            }

         int l1, r1;

         int  sum = 0;

        for(int i = 1; i <= n; i++){

            l1 = i - L[i], r1 = R[i] - i ;

            sum = (l1 * r1 % mod + sum) % mod;

        }

        printf("%d\n", sum);

    }

    return 0;

}

  

你可能感兴趣的:(sequence)