HDU 3530 Subsequence(单调队列)

 

Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2641    Accepted Submission(s): 869


Problem Description
There is a sequence of integers. Your task is to find the longest subsequence that satisfies the following condition: the difference between the maximum element and the minimum element of the subsequence is no smaller than m and no larger than k.
 

 

Input
There are multiple test cases.
For each test case, the first line has three integers, n, m and k. n is the length of the sequence and is in the range [1, 100000]. m and k are in the range [0, 1000000]. The second line has n integers, which are all in the range [0, 1000000].
Proceed to the end of file.
 

 

Output
For each test case, print the length of the subsequence on a single line.
 

 

Sample Input
5 0 0 1 1 1 1 1 5 0 3 1 2 3 4 5
 

 

Sample Output
5 4
 

 

Source
 

 

Recommend
zhengfeng
 
 
 
单调队列。
用两个单调队列维护最大值和最小值。
 
 
#include<stdio.h>

#include<iostream>

#include<algorithm>

#include<string.h>

using namespace std;



const int MAXN=100010;

int q1[MAXN],q2[MAXN];

int rear1,head1;

int rear2,head2;

int a[MAXN];

int main()

{

  //  freopen("in.txt","r",stdin);

  //  freopen("out.txt","w",stdout);

    int n,m,k;



    while(scanf("%d%d%d",&n,&m,&k)!=EOF)

    {

        rear1=head1=0;

        rear2=head2=0;

        int ans=0;

        int now=1;

        for(int i=1;i<=n;i++)

        {

            scanf("%d",&a[i]);

            while(head1<rear1&&a[q1[rear1-1]]<a[i])rear1--;//这里的等号取和不取都可以的

            while(head2<rear2&&a[q2[rear2-1]]>a[i])rear2--;

            q1[rear1++]=i;

            q2[rear2++]=i;

            while(head1<rear1&&head2<rear2&&a[q1[head1]]-a[q2[head2]]>k)

            {

                if(q1[head1]<q2[head2])now=q1[head1++]+1;

                else now=q2[head2++]+1;

            }

            if(head1<rear1&&head2<rear2&&a[q1[head1]]-a[q2[head2]]>=m)

            {

                //int t=min(q1[head1],q2[head2]);

                if(ans<i-now+1)ans=i-now+1;

            }

        }

        printf("%d\n",ans);

    }

    return 0;

}

 

你可能感兴趣的:(sequence)