F:Flip Game
!!!!!!!!!!!!!!!!!!!!!!!
代码存在bug!!!!!
!!!!!!!!!!!
助教GG帮我试了20万组随机数据,和ac的代码产生的结果都是一样的。。
可能是输入的问题
总时间限制:
1000ms
内存限制:
65536kB
描述
Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
Choose any one of the 16 pieces.
Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).
Consider the following position as an example:
bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:
bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the miimum number of rounds needed to achieve this goal.
输入
The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.
输出
Write to the output file a single integer number - the miimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).
样例输入
bwwb
bbwb
bwwb
bwww
样例输出
4*/
!!!!!!!!!
代码有bug
#include <cstdio>
#include <iostream>
using namespace std;
bool mp[6][6] = {0};
bool swit[2][6][6] = {0};
bool cop[2][6][6] = {0};
int mi = 20;
char in;
void changeswit(int i, int j, int c)
{
cop[c][i][j] = !cop[c][i][j];
cop[c][i-1][j] = !cop[c][i-1][j];
cop[c][i+1][j] = !cop[c][i+1][j];
cop[c][i][j-1] = !cop[c][i][j-1];
cop[c][i][j+1] = !cop[c][i][j+1];
}
int main()
{
mi = 20;
for(int i = 1; i <= 4; i++)
{
for(int j = 1; j <= 4; j++)
{
scanf("%c", &in);
if(in == 'w') mp[i][j] = 1;
else mp[i][j] = 0;
}
getchar();
}
for(int k = 0; k < 16; k++)
{
//printf("\n");
for(int i = 1; i <= 4; i++)
for(int j = 1; j <= 4; j++)
{
cop[0][i][j] = mp[i][j];
cop[1][i][j] = mp[i][j];
swit[0][i][j] = 0;
swit[1][i][j] = 0;
}
for(int j = 1; j <= 4; j++)
{swit[0][1][j] = (k >> (j-1)) & 1;
swit[1][1][j] = swit[0][1][j];
if(swit[0][1][j]) {changeswit(1, j, 0); changeswit(1, j, 1);}}
for(int i = 2; i <= 4; i++)
for(int j = 1; j <= 4; j++)
{
if(!cop[0][i-1][j])
{
swit[0][i][j] = 1;
changeswit(i,j,0);
}
if(cop[1][i-1][j])
{
swit[1][i][j] = 1;
changeswit(i,j,1);
}
}
int sum1 = 0, sum2 = 0;
for(int j = 1; j <= 4; j++)
{
sum1 += cop[0][4][j];
sum2 += cop[1][4][j];
}
if(sum1 == 4)
{
sum1 = 0;
for(int i = 1; i <= 4; i++)
for(int j = 1; j <= 4; j++)
sum1 += swit[0][i][j];
if(mi > sum1) mi = sum1;
}
if(sum2 == 0)
{
sum2 = 0;
for(int i = 1; i <= 4; i++)
for(int j = 1; j <= 4; j++)
sum2 += swit[1][i][j];
if(mi > sum2) mi = sum2;
}
}
if(mi == 20) printf("Impossible\n");
else printf("%d\n", mi);
return 0;
}
请大神指教,哪里不对?
可能是开始的输入有问题