POJ1007·DNA Sorting

一道水题,算法也没用多么复杂的,但在G++环境下提交成功,C++会报编译不过的错误。

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

#include<iostream>
#include<string>
using namespace std;

int main(){
	int m,n;
	cin>>n>>m;
	string str[m];
	int num[m];
	for(int i=0;i<m;i++){
		num[i]=0;
	}
	for(int i=0;i<m;i++){
		cin>>str[i];
		for(int j=0;j<n-1;j++){
			for(int k=j+1;k<n;k++){
				if(str[i].at(j)>str[i].at(k)){
					num[i]++;
				}
			}
		}
	}
	for(int i=0;i<m-1;i++){
		for(int j=i+1;j<m;j++){
			if(num[i]>num[j]){
				int temp;
				string strtemp;
				temp=num[i];
				strtemp=str[i];
				num[i]=num[j];
				str[i]=str[j];
				num[j]=temp;
				str[j]=strtemp;
			}
		}
	}
	for(int i=0;i<m;i++){
		cout<<str[i]<<endl;
	}
	return 0;
}

你可能感兴趣的:(POJ1007·DNA Sorting)