HSRP配置
1、 实验目的:
通过本次的实验,我们可以掌握如下技能
1) 理解HSRP的工作原理
2) 掌握HSRP的配置
2、 实验拓扑图:
3、 实验步骤:
(1) 配置IP地址和路由协议
R1(config)#interface g0/0
R1(config-if)#ip address 192.168.13.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)#interface s0/0
R1(config-if)#ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)#router rip
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.13.0
R1(config-router)#passive-interface g0/0
//把g0/0设置为被动接口,是为了防止从该接口发送rip信息
R2(config)#interface g0/0
R2(config-if)#ip address 192.168.20.2 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface s0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#clock rate 128000
R2(config-if)#no shutdown
R2(config)#interface s0/1
R2(config-if)#ip address 192.168.23.2 255.255.255.0
R2(config-if)#clock rate 128000
R2(config-if)#no shutdown
R2(config)#router rip
R2(config-router)#network 192.168.12.0
R2(config-router)#network 192.168.23.0
R2(config-router)#network 192.168.20.0
R2(config-router)#passive-interface g0/0
R3(config)#interface g0/0
R3(config-if)#ip address 192.168.13.3 255.255.255.0
R3(config-if)#no shutdown
R3(config)#interface s0/1
R3(config-if)#ip address 192.168.23.2 255.255.255.0
R3(config-if)#no shutdown
R3(config)#router rip
R3(config-router)#network 192.168.23.0
R3(config-router)#network 192.168.13.0
R3(config-router)#passive-interface g0/0
(2)配置 HSRP
R1(config)#interface g0/0
R1(config-if)#standby 1 ip 192.168.13.254
//启用HSRP功能,并配置虚拟IP地址,1为standby的组号,相同的组号的路由器属于同一个HSRP,所以属于同一个HSRP组的路由器的虚拟IP地址必须一致。
R1(config-if)#standby 1 priority 120
//配置HSRP的优先级,如果不配置默认是100
R1(config-if)#standby 1 times 3 10
//其中3为hello的次数,表示路由器每间隔多长的时间发送hello信息,10 为hold time 表示在多长的时间内同组的其他路由器没有收到激活路由器的信息,则认为该路由器出现了故障。
R1(config-if)#standby 1 preempt
//该设置允许该路由器在优先级最高的时候激活路由器。如果不设置,该路由器的权值在高,也不会激活路由器。
R1(config-if)#standby 1 authentication md5 key-string benet
//配置HSRP的认证密码,防止非法的用户加入到HSRP组中,同一个组的秘密必须一致。
R2(config)#interface g0/0
R2(config-if)#standby 1 ip 192.168.13.254
R2(config-if)#standby 1 priority 120
R2(config-if)#standby 1 times 3 10
R2(config-if)#standby 1 preempt
R2(config-if)#standby 1 authentication md5 key-string benet
OK,完成!!!!!!!