Description
While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith's telephone number was 493-7775. This number can be written as the product of its prime factors in the following way:
4937775= 3*5*5*65837
The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers.
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition.
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!
Input
The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.
Output
For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.
Sample Input
4937774
0
Sample Output
4937775
#include <iostream>
using namespace std;
int sumOfDigits (int n){
int sum = 0;
while(n){
sum += n % 10;
n = n/10;
}
return sum;
}
int isprime(int n){
for(int i = 2;i * i <= n ;i++)
if(n % i == 0)
return 0;
return 1;
}
int sumOfPrime(int n){
int sum = 0,i = 2;
while(1){
if(n % i == 0){
sum += sumOfDigits(i);
n = n / i;
if(isprime(n))
break;
}else{
i++;
}
}
return sum += sumOfDigits(n);
}
int main()
{
int n;
while(cin >> n && n){
while(1){
n++;
if(!isprime(n)){
if(sumOfDigits(n) == sumOfPrime(n)){
cout << n << endl;
break;
}
}
}
}
return 0;
}
附上质因数分解的程序(用递归解决)
#include <iostream>
using namespace std;
int isPrime(int n)
{
for(int i = 2;i * i <= n;i++)
if(n % i == 0)
return 0;
return 1;
}
void prime(int n)
{
if(isPrime(n)){
cout << n << endl;
return;
}
int i = 2;
while(1){
if(n % i ==0){
cout << i << "*";
prime(n / i);
break;
}
i++;
}
}
int main()
{
int n;
while(cin >> n){
prime(n);
}
return 0;
}