HDOJ A/B 1576【扩展欧几里得+求逆元】

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2996    Accepted Submission(s): 2238


Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
 

Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
 

Output
对应每组数据输出(A/B)%9973。
 

Sample Input
   
   
   
   
2 1000 53 87 123456789
 

Sample Output
   
   
   
   
7922 6060
 

Author
xhd
 

Source
HDU 2007-1 Programming Contest
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1788  1211  1787  1299  1573 
 

主要求B的逆元~

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define MOD 9973
using namespace std;

typedef long long LL;

LL extgct(LL a,LL b,LL &x,LL &y)
{
	LL d=a;
	if(b!=0)
	{
		d=extgct(b,a%b,y,x);
		y-=(a/b)*x;
	}
	else 
	{
		x=1;y=0;
	}
	return d;
}
//求逆元
//ax=1 (mod n);
LL mod_reverse(LL a,LL n)
{
	LL x,y;
	LL d=extgct(a,n,x,y);
	if(d==1) return (x%n+n)%n;
	else return -1;
} 

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		LL n,b;
		scanf("%lld%lld",&n,&b);
		LL d=mod_reverse(b,MOD);
		printf("%lld\n",n*d%MOD);
	}
	return 0;
}


你可能感兴趣的:(HDOJ A/B 1576【扩展欧几里得+求逆元】)