HDU2041

http://acm.hdu.edu.cn/showproblem.php?pid=2041

超级楼梯

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18728    Accepted Submission(s): 9592


Problem Description
有一楼梯共M级,刚开始时你在第一级,若每次只能跨上一级或二级,要走上第M级,共有多少种走法?
 

Input
输入数据首先包含一个整数N,表示测试实例的个数,然后是N行数据,每行包含一个整数M(1<=M<=40),表示楼梯的级数。
 

Output
对于每个测试实例,请输出不同走法的数量
 

Sample Input
   
   
   
   
2 2 3
 

Sample Output
   
   
   
   
1 2

题意 
有一楼梯共M级,刚开始时你在第一级,
若每次只能跨上一级或二级,要走上第M级,共有多少种走法?
思路:斐波那契数列
 


斐波那契數列

公式

s[1] = s[2] = 1;

s[n] = s[n-1] + s[n-2] (n > 2);


#include<iostream>

using namespace std;

int s[41];

int main(){
	int n,t;
	cin>>n;
	s[1]=s[2]=1;
	for(int i=3;i<=40;i++)
		s[i]=s[i-1]+s[i-2];
	while(n--){
		cin>>t;
		cout<<s[t]<<endl;
	}
	return 0;	
}



你可能感兴趣的:(HDU2041)