poj 1961 Period 【KMP】

Period
Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 15428   Accepted: 7397

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

计算字符串的前缀中的最小循环节,要求输出  前缀长度 和 最小循环节循环次数(>=2)

AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Sch(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define INF 0x3f3f3f3f
#define mod 10007
#define LL longlong
#include<algorithm>
using namespace std;
const int N = 1000000+10;
char s[N];
int p[N];
int ls;
int num[N];
void getp()
{
	int i = 0, j = -1;
	p[i] = j;
	while(i < ls)
	{
		if(j==-1||s[i]==s[j])
		{
			i++, j++;
			p[i] = j;
		}
		else  j = p[j];
	}
}
int main()
{
	int t = 1, n;
	while(Si(n), n)
	{
		Sch(s);
		ls = n;
		getp();
		printf("Test case #%d\n", t++);
		for(int i = 1; i <= n; i++)
		{
			int j = i;
			if(p[j]==0)  continue;
			if(j % (j - p[j])==0)  printf("%d %d\n", i, j/(j-p[j]));
		}
		printf("\n");
	}
	return 0;
} 



你可能感兴趣的:(poj 1961 Period 【KMP】)